Wamp Server 2.0

Test server, local de geliştirme için windows üzerinde çalışan sunucu programları ve Geliştirme, editör programları.
Kullanıcı avatarı
Gökhan
Deneyimli Üye
Deneyimli Üye
Mesajlar: 390
Kayıt: 11 Şub 2009, 22:57

Wamp Server 2.0

Mesaj gönderen Gökhan » 12 Şub 2009, 23:55

PHP Scriptlerinizi kendi bilgisayarınızda(Windows) test edebilmeniz için kullanabileceğiniz iyi bir program.

Programı indirip kurduktan sonra, sisteminize Apache (HTTP Sunucusu), PHP Yorumlayıcısı ve MySQL (DB Sunucu) veritabanı sunucusu ile birikte ayrıca PhpMyAdmin Hazır MySQL veritabanı yönetim scripti gelmektedir.

Programı kurup çalıştırdıktan sonra system tray üzerinde programın simgesi belirecektir, bu simge üzerinde ilk önce sağ tıklayarak dilerseniz Language seçeneğinden program dilini Türkçe'ye çevirebilisiniz.

Simge üzerinde sol tıkladığınızda program menüsü açılacaktır, buradan ilk önce tüm servisleri çevrim içi hale getirin. Daha sonra PHP->PHP Ayarları kısmından short open tag seçeneğini aktif hale getirin, bu özellik kısa tag açılımlarına izin veriyor, <?php yerine <? kullanabilmenizi sağlıyor. Register Globals, Safe Mode gibi ayarlamaları da isteğiniz doğrultusunda yapabilirisiniz. Bu bölümde yapacağınız her değişiklikten sonra servisler yeniden başlatılacaktır. Simge önce kırmızı, sonra sarı ve en sonunda da beyaza dönüşecektir.


Anasayfası : http://www.wampserver.com/en/
İndirme : http://www.wampserver.com/en/download.php

Kullanıcı avatarı
cantillman
Yeni Üye
Yeni Üye
Mesajlar: 9
Kayıt: 14 Şub 2009, 20:17

Re: Wamp Server 2.0

Mesaj gönderen cantillman » 15 Şub 2009, 14:08

evet ben kullanıyorum çok memnunum herkese tavsiye derim..

goldpulse
Yeni Üye
Yeni Üye
Mesajlar: 7
Kayıt: 04 Mar 2009, 16:00

Re: Wamp Server 2.0

Mesaj gönderen goldpulse » 11 Mar 2009, 22:05

merhaba bende kurdum kullanıyordum. sayfalarımı kendi pc de denemek için kodlamalrın olup olmadığını denemek için kullanıyordum. hiç bi sorun yoktu şimdi phpmyadmin diyorum ama admin bölümü açılmıyor. bağlantı kurulamadı diyor. yani explorer sayfası açılıyır ama sayfa görüntülenemiyor. ne yapmam gerek bilginiz varsa aydınlatırsanız çok sevinirim

Kullanıcı avatarı
seRdaL
Yeni Üye
Yeni Üye
Mesajlar: 4
Kayıt: 11 Mar 2009, 22:40

Re: Wamp Server 2.0

Mesaj gönderen seRdaL » 11 Mar 2009, 22:48

goldpulse yazdı:merhaba bende kurdum kullanıyordum. sayfalarımı kendi pc de denemek için kodlamalrın olup olmadığını denemek için kullanıyordum. hiç bi sorun yoktu şimdi phpmyadmin diyorum ama admin bölümü açılmıyor. bağlantı kurulamadı diyor. yani explorer sayfası açılıyır ama sayfa görüntülenemiyor. ne yapmam gerek bilginiz varsa aydınlatırsanız çok sevinirim
problemin tam olarak ne oldugunu cozemedim ama programi kaLdirip tekrar buLundugu yere kurarsan veritabanLari faLan kayboLmadan yeniLemis oLursun, o zaman caLisabiLir :)

Kullanıcı avatarı
Gökhan
Deneyimli Üye
Deneyimli Üye
Mesajlar: 390
Kayıt: 11 Şub 2009, 22:57

Re: Wamp Server 2.0

Mesaj gönderen Gökhan » 11 Mar 2009, 23:41

Sayfa görüntüleniyor ancak mysql sunucu hatası alıyorsanız mysql de bir sorun olabilir, başka bir program ya da firewall, mysql i bloklayan birşey olmuş olabilir. seRdaL'ın da belirttiği gibi yeniden kurulum sorunu çözebilir.


Dip Not : Her ne kadar varolan klasörler yeniden oluşturulmasa ve eski çalışmalarınız korunsa da, yeniden kurulum işleminden önce yedek almanızı öneririm. Ve belirli aralıklarla dayedek almanız yararınıza olacaktır.

goldpulse
Yeni Üye
Yeni Üye
Mesajlar: 7
Kayıt: 04 Mar 2009, 16:00

Re: Wamp Server 2.0

Mesaj gönderen goldpulse » 12 Mar 2009, 14:16

Arkadaşlar zaten silip yeniden yüklemiştim ama olmadı . ustam wampserver dan php myadmine tıkladığımda kontrol paneli hiç karşıma gelmiyor sayfa görüntülenemedi diyor. vista business kullanıyorum. uyumsuzluk olabilirmi. eğer olmayacaksa bunun gibi başka bir program varmı önerebileceğiniz teşekkürler

Kullanıcı avatarı
Gökhan
Deneyimli Üye
Deneyimli Üye
Mesajlar: 390
Kayıt: 11 Şub 2009, 22:57

Re: Wamp Server 2.0

Mesaj gönderen Gökhan » 12 Mar 2009, 16:08

Bu işletim siseminde hiç kullanmadım ancak menüden değil de http://localhost/phpmyadmin ile tarayıcıdan da doğrudan açılmıyor mu, buna benzer bir sorun bir kişi daha yaşamıştı menüden açmıyor ama doğrudan yazınca açılıyordu.

Bir de Alias kontrolü yapın, phpmyadmin klasörü farklı bir dizinde,

Menüde Apache->Kısayol Adresleri->http://localhost/phpmyadmin->Edit Alias kısmını konrol edin.

Wamp server dışında Easy PHP kullanabilirsiniz ancak kurulum ve kullanım konusunda fazla bilgim yok.

3m1Rr
Yeni Üye
Yeni Üye
Mesajlar: 1
Kayıt: 17 May 2009, 14:21

Re: Wamp Server 2.0

Mesaj gönderen 3m1Rr » 17 May 2009, 14:25

aynı sorun bende de oluyor ne yaptıysam çözüm bulamadım çözmüş olan arkadaşlar cevap yazarsa sevinirim...

Kullanıcı avatarı
Gökhan
Deneyimli Üye
Deneyimli Üye
Mesajlar: 390
Kayıt: 11 Şub 2009, 22:57

Re: Wamp Server 2.0

Mesaj gönderen Gökhan » 17 May 2009, 22:47

3m1Rr yazdı:aynı sorun bende de oluyor ne yaptıysam çözüm bulamadım çözmüş olan arkadaşlar cevap yazarsa sevinirim...
C:\wamp\alias içerisinde bulunan phpmyadmin.conf dosyasındaki aşağıdaki bölümde, yazan phpmyadmin klasörü ile, wamp klasörü içerisinde bulunan apps klasöründeki phpmyadmin klasörünün isminin aynı olduğundan emin olun ve değil ise klasör ismini değiştirerek tekrar deneyin.

Kod: Tümünü seç

Alias /phpmyadmin "c:/wamp/apps/phpmyadmin2.11.6/" 

<Directory "c:/wamp/apps/phpmyadmin2.11.6/">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride all
        Order Deny,Allow
	Deny from all
	Allow from 127.0.0.1
</Directory>

RedAndGreen
Üye
Üye
Mesajlar: 10
Kayıt: 03 Haz 2009, 01:18

Re: Wamp Server 2.0

Mesaj gönderen RedAndGreen » 03 Haz 2009, 17:51

ben appserver kullanıyorum aynı şey dimi???
RedAndGreen http://www.gediz-log.com
social enginer hakkında yardım almak istiyenler emo-fans@win....com

Cevapla

Kimler çevrimiçi

Bu forumu görüntüleyen kullanıcılar: Hiç bir kayıtlı kullanıcı yok ve 1 misafir